What’s Vulnerable › Vulnerabilities
CVE-2023-24957: IBM Business Automation Workflow cross-site scripting
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-05-06 · updated 2026-06-17
- Weakness: CWE-79
Description
IBM Business Automation Workflow 18.0.0.0, 18.0.0.1, 18.0.0.2, 19.0.0.1, 19.0.0.2, 19.0.0.3, 20.0.0.1, 20.0.0.2, 21.0.2, 21.0.3, 22.0.1, and 22.0.2 is vulnerable to cross-site scripting. This vulnerability allows users to embed arbitrary JavaScript code in the Web UI thus altering the intended functionality potentially leading to credentials disclosure within a trusted session. IBM X-Force ID: 246115.
Affected products
- IBM Business Automation Workflow: from 19.0.0.1 through 19.0.0.3; from 20.0.0.1 before 21.0.3; from 21.0.1 through 21.0.3.1; from 22.0.1 before 22.0.2; 18.0.0.0, 18.0.0.1, 18.0.0.2, 20.0.0.1, 20.0.0.2, 21.0.3 (+17) — fixed in 21.0.3, 22.0.2
How to fix
Upgrade to a fixed version: IBM Business Automation Workflow 21.0.3, 22.0.2. Check the vendor advisory for mitigations.
References
- https://exchange.xforce.ibmcloud.com/vulnerabilities/246115
- https://www.ibm.com/support/pages/node/6965776
- https://exchange.xforce.ibmcloud.com/vulnerabilities/246115
- https://www.ibm.com/support/pages/node/6965776
Get alerted when CVE-2023-24957 or the next vulnerability affects your stack