What’s Vulnerable › Vulnerabilities
CVE-2023-24966: IBM WebSphere Application Server cross-site scripting
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-04-27 · updated 2026-06-17
- Weakness: CWE-79
Description
IBM WebSphere Application Server 8.5 and 9.0 is vulnerable to cross-site scripting. This vulnerability allows users to embed arbitrary JavaScript code in the Web UI thus altering the intended functionality potentially leading to credentials disclosure within a trusted session. IBM X-Force ID: 246904.
Affected products
- IBM WebSphere Application Server: from 8.5.0.0 before 8.5.5.24; from 9.0.0.0 before 9.0.5.16 — fixed in 8.5.5.24, 9.0.5.16
How to fix
Upgrade to a fixed version: IBM WebSphere Application Server 8.5.5.24, 9.0.5.16. Check the vendor advisory for mitigations.
References
- https://exchange.xforce.ibmcloud.com/vulnerabilities/246904
- https://www.ibm.com/support/pages/node/6986333
- https://exchange.xforce.ibmcloud.com/vulnerabilities/246904
- https://www.ibm.com/support/pages/node/6986333
Get alerted when CVE-2023-24966 or the next vulnerability affects your stack