What’s Vulnerable › Vulnerabilities
CVE-2023-25141: JNDI injection into Apache sling-org-apache-sling-jcr-base
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-02-14 · updated 2026-06-17
- Weakness: CWE-74
Description
Apache Sling JCR Base < 3.1.12 has a critical injection vulnerability when running on old JDK versions (JDK 1.8.191 or earlier) through utility functions in RepositoryAccessor. The functions getRepository and getRepositoryFromURL allow an application to access data stored in a remote location via JDNI and RMI. Users of Apache Sling JCR Base are recommended to upgrade to Apache Sling JCR Base 3.1.12 or later, or to run on a more recent JDK.
Affected products
- Apache Software Foundation Apache Sling JCR Base: from 2.0.6 before 3.1.12 — fixed in 3.1.12
How to fix
Upgrade to a fixed version: Apache Software Foundation Apache Sling JCR Base 3.1.12. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2023-25141 or the next vulnerability affects your stack