What’s Vulnerable › Vulnerabilities
CVE-2023-25155: Integer Overflow in several Redis commands can lead to denial of service.
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.9% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-03-02 · updated 2026-06-17
- Weakness: CWE-190
Description
Redis is an in-memory database that persists on disk. Authenticated users issuing specially crafted `SRANDMEMBER`, `ZRANDMEMBER`, and `HRANDFIELD` commands can trigger an integer overflow, resulting in a runtime assertion and termination of the Redis server process. This problem affects all Redis versions. Patches were released in Redis version(s) 6.0.18, 6.2.11 and 7.0.9.
Affected products
- Redis: before 6.0.18; from 6.2.0 before 6.2.11; from 7.0.0 before 7.0.9 — fixed in 6.0.18, 6.2.11, 7.0.9
How to fix
Upgrade to a fixed version: Redis 6.0.18, 6.2.11, 7.0.9. Check the vendor advisory for mitigations.
References
- https://github.com/redis/redis/commit/2a2a582e7cd99ba3b531336b8bd41df2b566e619
- https://github.com/redis/redis/releases/tag/6.0.18
- https://github.com/redis/redis/releases/tag/6.2.11
- https://github.com/redis/redis/releases/tag/7.0.9
- https://github.com/redis/redis/security/advisories/GHSA-x2r7-j9vw-3w83
- https://github.com/redis/redis/commit/2a2a582e7cd99ba3b531336b8bd41df2b566e619
- https://github.com/redis/redis/releases/tag/6.0.18
- https://github.com/redis/redis/releases/tag/6.2.11
- https://github.com/redis/redis/releases/tag/7.0.9
- https://github.com/redis/redis/security/advisories/GHSA-x2r7-j9vw-3w83
Get alerted when CVE-2023-25155 or the next vulnerability affects your stack