What’s Vulnerable › Vulnerabilities
CVE-2023-25164: Sensitive Information leak via Script File in TinaCMS
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.7% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-02-08 · updated 2026-06-17
- Weakness: CWE-200
Description
Tinacms is a Git-backed headless content management system with support for visual editing. Sites being built with @tinacms/cli >= 1.0.0 && < 1.0.9 which store sensitive values in the process.env variable are impacted. These values will be added in plaintext to the index.js file. If you're on a version prior to 1.0.0 this vulnerability does not affect you. If you are affected and your Tina-enabled website has sensitive credentials stored as environment variables (eg. Algolia API keys) you should rotate those keys immediately. This issue has been patched in @tinacms/cli@1.0.9. Users are advised to upgrade. There are no known workarounds for this issue.
Affected products
- tinacms: from 1.0.0 before 1.0.9 — fixed in 1.0.9
How to fix
Upgrade to a fixed version: tinacms 1.0.9. Check the vendor advisory for mitigations.
References
- https://github.com/tinacms/tinacms/pull/3584
- https://github.com/tinacms/tinacms/security/advisories/GHSA-pc2q-jcxq-rjrr
- https://github.com/tinacms/tinacms/pull/3584
- https://github.com/tinacms/tinacms/security/advisories/GHSA-pc2q-jcxq-rjrr
Get alerted when CVE-2023-25164 or the next vulnerability affects your stack