What’s Vulnerable › Vulnerabilities
CVE-2023-25167: Regular expression denial of service via installing themes via git in discourse
- Severity: medium (CVSS 5.7 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-02-08 · updated 2026-06-17
- Weakness: CWE-1333
Description
Discourse is an open source discussion platform. In affected versions a malicious user can cause a regular expression denial of service using a carefully crafted git URL. This issue is patched in the latest stable, beta and tests-passed versions of Discourse. Users are advised to upgrade. There are no known workarounds for this issue.
Affected products
- discourse: before 3.0.1; 3.1.0-beta1 — fixed in 3.0.1
How to fix
Upgrade to a fixed version: discourse 3.0.1. Check the vendor advisory for mitigations.
References
- https://github.com/discourse/discourse/commit/ec4c30270887366dc28788bc4ab8a22a098573cd
- https://github.com/discourse/discourse/security/advisories/GHSA-4w55-w26q-r35w
- https://github.com/discourse/discourse/commit/ec4c30270887366dc28788bc4ab8a22a098573cd
- https://github.com/discourse/discourse/security/advisories/GHSA-4w55-w26q-r35w
Get alerted when CVE-2023-25167 or the next vulnerability affects your stack