What’s Vulnerable › Vulnerabilities
CVE-2023-25168: Symbolic Link (Symlink) Following allowing the deletion of files and directories on the host system in wings
- Severity: high (CVSS 8.2 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.0% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-02-09 · updated 2026-06-17
- Weakness: CWE-59
Description
Wings is Pterodactyl's server control plane. This vulnerability can be used to delete files and directories recursively on the host system. This vulnerability can be combined with `GHSA-p8r3-83r8-jwj5` to overwrite files on the host system. In order to use this exploit, an attacker must have an existing "server" allocated and controlled by Wings. This vulnerability has been resolved in version `v1.11.4` of Wings, and has been back-ported to the 1.7 release series in `v1.7.4`. Anyone running `v1.11.x` should upgrade to `v1.11.4` and anyone running `v1.7.x` should upgrade to `v1.7.4`. There are no known workarounds for this issue.
Affected products
- pterodactyl wings: from 1.7.0 before 1.7.4; 1.11.0, 1.11.1, 1.11.2, 1.11.3 — fixed in 1.7.4
How to fix
Upgrade to a fixed version: pterodactyl wings 1.7.4. Check the vendor advisory for mitigations.
References
- https://github.com/pterodactyl/wings/commit/429ac62dba22997a278bc709df5ac00a5a25d83d
- https://github.com/pterodactyl/wings/security/advisories/GHSA-66p8-j459-rq63
- https://github.com/pterodactyl/wings/security/advisories/GHSA-p8r3-83r8-jwj5
- https://github.com/pterodactyl/wings/commit/429ac62dba22997a278bc709df5ac00a5a25d83d
- https://github.com/pterodactyl/wings/security/advisories/GHSA-66p8-j459-rq63
- https://github.com/pterodactyl/wings/security/advisories/GHSA-p8r3-83r8-jwj5
Get alerted when CVE-2023-25168 or the next vulnerability affects your stack