What’s Vulnerable › Vulnerabilities
CVE-2023-25170: PrestaShop has possible CSRF token fixation
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-03-13 · updated 2026-06-17
- Weakness: CWE-352
Description
PrestaShop is an open source e-commerce web application that, prior to version 8.0.1, is vulnerable to cross-site request forgery (CSRF). When authenticating users, PrestaShop preserves session attributes. Because this does not clear CSRF tokens upon login, this might enable same-site attackers to bypass the CSRF protection mechanism by performing an attack similar to a session-fixation. The problem is fixed in version 8.0.1.
Affected products
- PrestaShop: before 8.0.1 — fixed in 8.0.1
How to fix
Upgrade to a fixed version: PrestaShop 8.0.1. Check the vendor advisory for mitigations.
References
- https://github.com/PrestaShop/PrestaShop/security/advisories/GHSA-3g43-x7qr-96ph
- https://github.com/PrestaShop/PrestaShop/security/advisories/GHSA-3g43-x7qr-96ph
Get alerted when CVE-2023-25170 or the next vulnerability affects your stack