What’s Vulnerable › Vulnerabilities
CVE-2023-25305
- Severity: high (CVSS 7.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2023-04-04 · updated 2026-06-17
- Weakness: CWE-22
Description
PolyMC Launcher <= 1.4.3 is vulnerable to Directory Traversal. A mrpack file can be maliciously crafted to create arbitrary files outside of the installation directory.
Affected products
- Polymc: before 5.0 — fixed in 5.0
How to fix
Upgrade to a fixed version: Polymc 5.0. Check the vendor advisory for mitigations.
References
- https://github.com/PolyMC/PolyMC/security/advisories/GHSA-3rfr-g9g9-7gx2
- https://quiltmc.org/en/blog/2023-02-04-five-installer-vulnerabilities/
- https://github.com/PolyMC/PolyMC/security/advisories/GHSA-3rfr-g9g9-7gx2
- https://quiltmc.org/en/blog/2023-02-04-five-installer-vulnerabilities/
Get alerted when CVE-2023-25305 or the next vulnerability affects your stack