What’s Vulnerable › Vulnerabilities
CVE-2023-25307
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2023-06-26 · updated 2026-06-17
- Weakness: CWE-22
Description
nothub mrpack-install <= v0.16.2 is vulnerable to Directory Traversal.
Affected products
- Mrpack-Install Project Mrpack-Install: before 0.16.3 — fixed in 0.16.3
How to fix
Upgrade to a fixed version: Mrpack-Install Project Mrpack-Install 0.16.3. Check the vendor advisory for mitigations.
References
- https://github.com/nothub/mrpack-install/security/advisories/GHSA-r887-gfxh-m9rr
- https://quiltmc.org/en/blog/2023-02-04-five-installer-vulnerabilities/
- https://github.com/nothub/mrpack-install/security/advisories/GHSA-r887-gfxh-m9rr
- https://quiltmc.org/en/blog/2023-02-04-five-installer-vulnerabilities/
Get alerted when CVE-2023-25307 or the next vulnerability affects your stack