What’s Vulnerable › Vulnerabilities
CVE-2023-25361
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.0% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-03-02 · updated 2026-06-17
- Weakness: CWE-416
Description
A use-after-free vulnerability in WebCore::RenderLayer::setNextSibling in WebKitGTK before 2.36.8 allows attackers to execute code remotely.
Affected products
- Webkit: before 2.36.8 — fixed in 2.36.8
How to fix
Upgrade to a fixed version: Webkit 2.36.8. Check the vendor advisory for mitigations.
References
- http://www.openwall.com/lists/oss-security/2023/04/21/3
- https://bugs.webkit.org/show_bug.cgi?id=244249
- https://security.gentoo.org/glsa/202305-32
- http://www.openwall.com/lists/oss-security/2023/04/21/3
- https://bugs.webkit.org/show_bug.cgi?id=244249
- https://security.gentoo.org/glsa/202305-32
Get alerted when CVE-2023-25361 or the next vulnerability affects your stack