What’s Vulnerable › Vulnerabilities
CVE-2023-25450: WordPress GiveWP Plugin <= 2.25.1 is vulnerable to Cross Site Request Forgery (CSRF)
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-06-15 · updated 2026-06-17
- Weakness: CWE-352
Description
Cross-Site Request Forgery (CSRF) vulnerability in GiveWP GiveWP – Donation Plugin and Fundraising Platform plugin <= 2.25.1 versions.
Affected products
- stellarwp GiveWP – Donation Plugin and Fundraising Platform: before 2.25.2 — fixed in 2.25.2
How to fix
Upgrade to a fixed version: stellarwp GiveWP – Donation Plugin and Fundraising Platform 2.25.2. Check the vendor advisory for mitigations.
References
- https://patchstack.com/database/vulnerability/give/wordpress-givewp-plugin-2-25-1-cross-site-request-forgery-csrf-via-give-cache-flush-vulnerability?_s_id=cve
- https://patchstack.com/database/vulnerability/give/wordpress-givewp-plugin-2-25-1-cross-site-request-forgery-csrf-via-give-cache-flush-vulnerability?_s_id=cve
Get alerted when CVE-2023-25450 or the next vulnerability affects your stack