What’s Vulnerable › Vulnerabilities
CVE-2023-25542
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.1% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-04-06 · updated 2026-06-17
- Weakness: CWE-276
Description
Dell Trusted Device Agent, versions prior to 5.3.0, contain(s) an improper installation permissions vulnerability. An unauthenticated local attacker could potentially exploit this vulnerability, leading to escalated privileges.
Affected products
- Dell Trusted Device Client: before 5.3.0 — fixed in 5.3.0
How to fix
Upgrade to a fixed version: Dell Trusted Device Client 5.3.0. Check the vendor advisory for mitigations.
References
- https://www.dell.com/support/kbdoc/en-us/000209461/dsa-2023-074
- https://www.dell.com/support/kbdoc/en-us/000209461/dsa-2023-074
Get alerted when CVE-2023-25542 or the next vulnerability affects your stack