What’s Vulnerable › Vulnerabilities
CVE-2023-2556: WPCS – WordPress Currency Switcher Professional <= 1.1.9 - Missing Authorization to Arbitrary Custom Drop-Down Currency Switcher Deletion
- Severity: medium (CVSS 4.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-06-09 · updated 2026-06-17
- Weakness: CWE-862
Description
The WPCS – WordPress Currency Switcher Professional plugin for WordPress is vulnerable to unauthorized modification of data due to a missing capability check on the anonymous function for the wpcs_sd_delete action in versions up to, and including, 1.1.9. This makes it possible for authenticated attackers, with subscriber-level permissions and above, to delete an arbitrary custom drop-down currency switcher.
Affected products
- PluginUS Wordpress Currency Switcher: before 1.2.0 — fixed in 1.2.0
How to fix
Upgrade to a fixed version: PluginUS Wordpress Currency Switcher 1.2.0. Check the vendor advisory for mitigations.
References
- https://plugins.trac.wordpress.org/changeset/2911049/currency-switcher
- https://www.wordfence.com/threat-intel/vulnerabilities/id/bc44c95e-9ca0-46d0-8315-72612ef3f855?source=cve
- https://plugins.trac.wordpress.org/changeset/2911049/currency-switcher
- https://www.wordfence.com/threat-intel/vulnerabilities/id/bc44c95e-9ca0-46d0-8315-72612ef3f855?source=cve
Get alerted when CVE-2023-2556 or the next vulnerability affects your stack