What’s Vulnerable › Vulnerabilities
CVE-2023-25561: Login fail open on JAAS misconfiguration in DataHub
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-02-11 · updated 2026-06-17
- Weakness: CWE-755
Description
DataHub is an open-source metadata platform. In the event a system is using Java Authentication and Authorization Service (JAAS) authentication and that system is given a configuration which contains an error, the authentication for the system will fail open and allow an attacker to login using any username and password. The reason for this is that while an error is thrown in the `authenticateJaasUser` method it is swallowed without propagating the error. As a result of this issue unauthenticated users may gain access to the system. Users are advised to upgrade. There are no known workarounds for this issue. This vulnerability was discovered and reported by the GitHub Security lab and is tracked as GHSL-2022-081.
Affected products
- datahub-project datahub: before 0.8.45 — fixed in 0.8.45
How to fix
Upgrade to a fixed version: datahub-project datahub 0.8.45. Check the vendor advisory for mitigations.
References
- https://github.com/datahub-project/datahub/blob/fdf4e48495f083314f59c414bcc7c2601633a2b8/datahub-frontend/app/security/AuthenticationManager.java#L26
- https://github.com/datahub-project/datahub/security/advisories/GHSA-7wc6-p6c4-522c
- https://github.com/datahub-project/datahub/blob/fdf4e48495f083314f59c414bcc7c2601633a2b8/datahub-frontend/app/security/AuthenticationManager.java#L26
- https://github.com/datahub-project/datahub/security/advisories/GHSA-7wc6-p6c4-522c
Get alerted when CVE-2023-25561 or the next vulnerability affects your stack