What’s Vulnerable › Vulnerabilities
CVE-2023-25564: GSS-NTLMSSP vulnerable to memory corruption when decoding UTF16 strings
- Severity: high (CVSS 8.2 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.9% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-02-14 · updated 2026-06-17
- Weakness: CWE-787
Description
GSS-NTLMSSP is a mechglue plugin for the GSSAPI library that implements NTLM authentication. Prior to version 1.2.0, memory corruption can be triggered when decoding UTF16 strings. The variable `outlen` was not initialized and could cause writing a zero to an arbitrary place in memory if `ntlm_str_convert()` were to fail, which would leave `outlen` uninitialized. This can lead to a denial of service if the write hits unmapped memory or randomly corrupts a byte in the application memory space. This vulnerability can trigger an out-of-bounds write, leading to memory corruption. This vulnerability can be triggered via the main `gss_accept_sec_context` entry point. This issue is fixed in version 1.2.0.
Affected products
- gssapi gss-ntlmssp: before 1.2.0 — fixed in 1.2.0
How to fix
Upgrade to a fixed version: gssapi gss-ntlmssp 1.2.0. Check the vendor advisory for mitigations.
References
- https://github.com/gssapi/gss-ntlmssp/commit/c753000eb31835c0664e528fbc99378ae0cbe950
- https://github.com/gssapi/gss-ntlmssp/releases/tag/v1.2.0
- https://github.com/gssapi/gss-ntlmssp/security/advisories/GHSA-r85x-q5px-9xfq
- https://github.com/gssapi/gss-ntlmssp/commit/c753000eb31835c0664e528fbc99378ae0cbe950
- https://github.com/gssapi/gss-ntlmssp/releases/tag/v1.2.0
- https://github.com/gssapi/gss-ntlmssp/security/advisories/GHSA-r85x-q5px-9xfq
Get alerted when CVE-2023-25564 or the next vulnerability affects your stack