What’s Vulnerable › Vulnerabilities
CVE-2023-25566: GSS-NTLMSSP vulnerable to memory leak when parsing usernames
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.1% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-02-14 · updated 2026-06-17
- Weakness: CWE-401
Description
GSS-NTLMSSP is a mechglue plugin for the GSSAPI library that implements NTLM authentication. Prior to version 1.2.0, a memory leak can be triggered when parsing usernames which can trigger a denial-of-service. The domain portion of a username may be overridden causing an allocated memory area the size of the domain name to be leaked. An attacker can leak memory via the main `gss_accept_sec_context` entry point, potentially causing a denial-of-service. This issue is fixed in version 1.2.0.
Affected products
- gssapi gss-ntlmssp: before 1.2.0 — fixed in 1.2.0
How to fix
Upgrade to a fixed version: gssapi gss-ntlmssp 1.2.0. Check the vendor advisory for mitigations.
References
- https://github.com/gssapi/gss-ntlmssp/commit/8660fb16474054e692a596e9c79670cd4d3954f4
- https://github.com/gssapi/gss-ntlmssp/releases/tag/v1.2.0
- https://github.com/gssapi/gss-ntlmssp/security/advisories/GHSA-mfm4-6g58-jw74
- https://github.com/gssapi/gss-ntlmssp/commit/8660fb16474054e692a596e9c79670cd4d3954f4
- https://github.com/gssapi/gss-ntlmssp/releases/tag/v1.2.0
- https://github.com/gssapi/gss-ntlmssp/security/advisories/GHSA-mfm4-6g58-jw74
Get alerted when CVE-2023-25566 or the next vulnerability affects your stack