What’s Vulnerable › Vulnerabilities
CVE-2023-25569: apollo-portal has potential CSRF issue
- Severity: medium (CVSS 5.7 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-02-20 · updated 2026-06-17
- Weakness: CWE-352
Description
Apollo is a configuration management system. Prior to version 2.1.0, a low-privileged user can create a special web page. If an authenticated portal admin visits this page, the page can silently send a request to assign new roles for that user without any confirmation from the Portal admin. Cookie SameSite strategy was set to Lax in version 2.1.0. As a workaround, avoid visiting unknown source pages.
Affected products
- apolloconfig apollo: before 2.1.0 — fixed in 2.1.0
How to fix
Upgrade to a fixed version: apolloconfig apollo 2.1.0. Check the vendor advisory for mitigations.
References
- https://github.com/apolloconfig/apollo/commit/00d968a7229f809b0d8ed0532e8c01a6c2b7c750
- https://github.com/apolloconfig/apollo/pull/4664
- https://github.com/apolloconfig/apollo/releases/tag/v2.1.0
- https://github.com/apolloconfig/apollo/security/advisories/GHSA-fmxq-v8mg-qh25
- https://www.apolloconfig.com/#/en/usage/apollo-user-guide?id=_71-security-related
- https://github.com/apolloconfig/apollo/commit/00d968a7229f809b0d8ed0532e8c01a6c2b7c750
- https://github.com/apolloconfig/apollo/pull/4664
- https://github.com/apolloconfig/apollo/releases/tag/v2.1.0
- https://github.com/apolloconfig/apollo/security/advisories/GHSA-fmxq-v8mg-qh25
- https://www.apolloconfig.com/#/en/usage/apollo-user-guide?id=_71-security-related
Get alerted when CVE-2023-25569 or the next vulnerability affects your stack