What’s Vulnerable › Vulnerabilities
CVE-2023-25570: Apollo has potential access control security issue in eureka
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.8% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-02-20 · updated 2026-06-17
- Weakness: CWE-306
Description
Apollo is a configuration management system. Prior to version 2.1.0, there are potential security issues if users expose apollo-configservice to the internet, which is not recommended. This is because there is no authentication feature enabled for the built-in eureka service. Malicious hackers may access eureka directly to mock apollo-configservice and apollo-adminservice. Login authentication for eureka was added in version 2.1.0. As a workaround, avoid exposing apollo-configservice to the internet.
Affected products
- apolloconfig apollo: before 2.1.0 — fixed in 2.1.0
How to fix
Upgrade to a fixed version: apolloconfig apollo 2.1.0. Check the vendor advisory for mitigations.
References
- https://github.com/apolloconfig/apollo/commit/7df79bf8df6960433ed4ff782a54e3dfc74632bd
- https://github.com/apolloconfig/apollo/pull/4663
- https://github.com/apolloconfig/apollo/releases/tag/v2.1.0
- https://github.com/apolloconfig/apollo/security/advisories/GHSA-368x-wmmg-hq5c
- https://github.com/apolloconfig/apollo/commit/7df79bf8df6960433ed4ff782a54e3dfc74632bd
- https://github.com/apolloconfig/apollo/pull/4663
- https://github.com/apolloconfig/apollo/releases/tag/v2.1.0
- https://github.com/apolloconfig/apollo/security/advisories/GHSA-368x-wmmg-hq5c
Get alerted when CVE-2023-25570 or the next vulnerability affects your stack