What’s Vulnerable › Vulnerabilities
CVE-2023-25571: Backstage has XSS Vulnerability in Software Catalog
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-02-14 · updated 2026-06-17
- Weakness: CWE-79
Description
Backstage is an open platform for building developer portals. `@backstage/catalog-model` prior to version 1.2.0, `@backstage/core-components` prior to 0.12.4, and `@backstage/plugin-catalog-backend` prior to 1.7.2 are affected by a cross-site scripting vulnerability. This vulnerability allows a malicious actor with access to add or modify content in an instance of the Backstage software catalog to inject script URLs in the entities stored in the catalog. If users of the catalog then click on said URLs, that can lead to an XSS attack. This vulnerability has been patched in both the frontend and backend implementations. The default `Link` component from `@backstage/core-components` version 1.2.0 and greater will now reject `javascript:` URLs, and there is a global override of `window.open` to do the same. In addition, the catalog model v0.12.4 and greater as well as the catalog backend v1.7.2 and greater now has additional validation built in that prevents `javascript:` URLs in known annotations. As a workaround, the general practice of limiting access to modifying catalog content and requiring code reviews greatly help mitigate this vulnerability.
Affected products
- Linuxfoundation Backstage Catalog-Model: before 1.2.0 — fixed in 1.2.0
- Linuxfoundation Backstage Core-Components: before 0.12.4 — fixed in 0.12.4
- Linuxfoundation Backstage Plugin-Catalog-Backend: before 1.7.2 — fixed in 1.7.2
How to fix
Upgrade to a fixed version: Linuxfoundation Backstage Catalog-Model 1.2.0; Linuxfoundation Backstage Core-Components 0.12.4; Linuxfoundation Backstage Plugin-Catalog-Backend 1.7.2. Check the vendor advisory for mitigations.
References
- https://github.com/backstage/backstage/commit/3d1371954512f7fa8bd0e2d357e00eada2c3e8a8
- https://github.com/backstage/backstage/security/advisories/GHSA-7hv8-3fr9-j2hv
- https://github.com/backstage/backstage/commit/3d1371954512f7fa8bd0e2d357e00eada2c3e8a8
- https://github.com/backstage/backstage/security/advisories/GHSA-7hv8-3fr9-j2hv
Get alerted when CVE-2023-25571 or the next vulnerability affects your stack