What’s Vulnerable › Vulnerabilities
CVE-2023-25608
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-09-13 · updated 2026-06-17
- Weakness: CWE-792
Description
An incomplete filtering of one or more instances of special elements vulnerability [CWE-792] in the command line interpreter of FortiAP-W2 7.2.0 through 7.2.1, 7.0.3 through 7.0.5, 7.0.0 through 7.0.1, 6.4 all versions, 6.2 all versions, 6.0 all versions; FortiAP-C 5.4.0 through 5.4.4, 5.2 all versions; FortiAP 7.2.0 through 7.2.1, 7.0.0 through 7.0.5, 6.4 all versions, 6.0 all versions; FortiAP-U 7.0.0, 6.2.0 through 6.2.5, 6.0 all versions, 5.4 all versions may allow an authenticated attacker to read arbitrary files via specially crafted command arguments.
Affected products
- Fortinet FortiAP: from 6.0.0 before 7.0.6; from 7.2.0 before 7.2.2 — fixed in 7.0.6, 7.2.2
- Fortinet FortiAP-C: from 5.2.0 before 5.4.5 — fixed in 5.4.5
- Fortinet FortiAP-U: from 5.4.0 before 6.2.6; 7.0.0 — fixed in 6.2.6
- Fortinet FortiAP-W2: from 6.0.0 through 7.0.1; from 7.0.3 before 7.0.6; from 7.2.0 before 7.2.2 — fixed in 7.0.6, 7.2.2
How to fix
Upgrade to a fixed version: Fortinet FortiAP 7.0.6, 7.2.2; Fortinet FortiAP-C 5.4.5; Fortinet FortiAP-U 6.2.6; Fortinet FortiAP-W2 7.0.6, 7.2.2. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2023-25608 or the next vulnerability affects your stack