What’s Vulnerable › Vulnerabilities

CVE-2023-25610

Description

A buffer underwrite ('buffer underflow') vulnerability in the administrative interface of Fortinet FortiOS version 7.2.0 through 7.2.3, version 7.0.0 through 7.0.6, version 6.4.0 through 6.4.11 and version 6.2.12 and below, FortiProxy version 7.2.0 through 7.2.2, version 7.0.0 through 7.0.8, version 2.0.12 and below and FortiOS-6K7K version 7.0.5, version 6.4.0 through 6.4.10 and version 6.2.0 through 6.2.10 and below allows a remote unauthenticated attacker to execute arbitrary code or commands via specifically crafted requests.

Affected products

How to fix

Upgrade to a fixed version: Fortinet FortiAnalyzer 6.0.12, 6.2.11, 6.4.12, 7.0.5; Fortinet FortiManager 6.0.12, 6.2.11, 6.4.12, 7.0.5; Fortinet FortiOS (FortiGate) 6.2.13, 6.4.12, 7.0.10, 7.2.4; Fortinet FortiOS-6K7K 6.2.13, 6.4.12; Fortinet FortiProxy 7.0.9, 7.2.3; Fortinet FortiSwitch 7.0.7, 7.2.4; Fortinet FortiSwitchManager 7.0.2, 7.2.2; Fortinet FortiWeb 6.1.4, 6.2.8, 6.3.23, 6.4.3. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2023-25610 or the next vulnerability affects your stack