What’s Vulnerable › Vulnerabilities
CVE-2023-25658: TensorFlow vulnerable to Out-of-Bounds Read in GRUBlockCellGrad
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-03-25 · updated 2026-06-17
- Weakness: CWE-125
Description
TensorFlow is an open source platform for machine learning. Prior to versions 2.12.0 and 2.11.1, an out of bounds read is in GRUBlockCellGrad. A fix is included in TensorFlow 2.12.0 and 2.11.1.
Affected products
- tensorflow: before 2.12.0 — fixed in 2.12.0
How to fix
Upgrade to a fixed version: tensorflow 2.12.0. Check the vendor advisory for mitigations.
References
- https://github.com/tensorflow/tensorflow/commit/ff459137c2716a2a60f7d441b855fcb466d778cb
- https://github.com/tensorflow/tensorflow/security/advisories/GHSA-68v3-g9cm-rmm6
- https://github.com/tensorflow/tensorflow/commit/ff459137c2716a2a60f7d441b855fcb466d778cb
- https://github.com/tensorflow/tensorflow/security/advisories/GHSA-68v3-g9cm-rmm6
Get alerted when CVE-2023-25658 or the next vulnerability affects your stack