What’s Vulnerable › Vulnerabilities
CVE-2023-25659: TensorFlow vulnerable to Out-of-Bounds Read in DynamicStitch
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-03-25 · updated 2026-06-17
- Weakness: CWE-125
Description
TensorFlow is an open source platform for machine learning. Prior to versions 2.12.0 and 2.11.1, if the parameter `indices` for `DynamicStitch` does not match the shape of the parameter `data`, it can trigger an stack OOB read. A fix is included in TensorFlow version 2.12.0 and version 2.11.1.
Affected products
- tensorflow: before 2.12.0 — fixed in 2.12.0
How to fix
Upgrade to a fixed version: tensorflow 2.12.0. Check the vendor advisory for mitigations.
References
- https://github.com/tensorflow/tensorflow/commit/ee004b18b976eeb5a758020af8880236cd707d05
- https://github.com/tensorflow/tensorflow/security/advisories/GHSA-93vr-9q9m-pj8p
- https://github.com/tensorflow/tensorflow/commit/ee004b18b976eeb5a758020af8880236cd707d05
- https://github.com/tensorflow/tensorflow/security/advisories/GHSA-93vr-9q9m-pj8p
Get alerted when CVE-2023-25659 or the next vulnerability affects your stack