What’s Vulnerable › Vulnerabilities
CVE-2023-25660: TensorFlow vulnerable to seg fault in `tf.raw_ops.Print`
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-03-25 · updated 2026-06-17
- Weakness: CWE-476
Description
TensorFlow is an open source platform for machine learning. Prior to versions 2.12.0 and 2.11.1, when the parameter `summarize` of `tf.raw_ops.Print` is zero, the new method `SummarizeArray<bool>` will reference to a nullptr, leading to a seg fault. A fix is included in TensorFlow version 2.12 and version 2.11.1.
Affected products
- tensorflow: before 2.12.0 — fixed in 2.12.0
How to fix
Upgrade to a fixed version: tensorflow 2.12.0. Check the vendor advisory for mitigations.
References
- https://github.com/tensorflow/tensorflow/commit/6d423b8bcc9aa9f5554dc988c1c16d038b508df1
- https://github.com/tensorflow/tensorflow/security/advisories/GHSA-qjqc-vqcf-5qvj
- https://github.com/tensorflow/tensorflow/commit/6d423b8bcc9aa9f5554dc988c1c16d038b508df1
- https://github.com/tensorflow/tensorflow/security/advisories/GHSA-qjqc-vqcf-5qvj
Get alerted when CVE-2023-25660 or the next vulnerability affects your stack