What’s Vulnerable › Vulnerabilities
CVE-2023-25661: Denial of Service in TensorFlow
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2023-03-27 · updated 2026-06-17
- Weakness: CWE-20
Description
TensorFlow is an Open Source Machine Learning Framework. In versions prior to 2.11.1 a malicious invalid input crashes a tensorflow model (Check Failed) and can be used to trigger a denial of service attack. A proof of concept can be constructed with the `Convolution3DTranspose` function. This Convolution3DTranspose layer is a very common API in modern neural networks. The ML models containing such vulnerable components could be deployed in ML applications or as cloud services. This failure could be potentially used to trigger a denial of service attack on ML cloud services. An attacker must have privilege to provide input to a `Convolution3DTranspose` call. This issue has been patched and users are advised to upgrade to version 2.11.1. There are no known workarounds for this vulnerability.
Affected products
- tensorflow: before 2.11.1 — fixed in 2.11.1
How to fix
Upgrade to a fixed version: tensorflow 2.11.1. Check the vendor advisory for mitigations.
References
- https://github.com/tensorflow/tensorflow/commit/948fe6369a5711d4b4568ea9bbf6015c6dfb77e2
- https://github.com/tensorflow/tensorflow/security/advisories/GHSA-fxgc-95xx-grvq
- https://github.com/tensorflow/tensorflow/commit/948fe6369a5711d4b4568ea9bbf6015c6dfb77e2
- https://github.com/tensorflow/tensorflow/security/advisories/GHSA-fxgc-95xx-grvq
Get alerted when CVE-2023-25661 or the next vulnerability affects your stack