What’s Vulnerable › Vulnerabilities
CVE-2023-25662: TensorFlow vulnerable to integer overflow in EditDistance
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-03-25 · updated 2026-06-17
- Weakness: CWE-190
Description
TensorFlow is an open source platform for machine learning. Versions prior to 2.12.0 and 2.11.1 are vulnerable to integer overflow in EditDistance. A fix is included in TensorFlow version 2.12.0 and version 2.11.1.
Affected products
- tensorflow: before 2.12.0 — fixed in 2.12.0
How to fix
Upgrade to a fixed version: tensorflow 2.12.0. Check the vendor advisory for mitigations.
References
- https://github.com/tensorflow/tensorflow/commit/08b8e18643d6dcde00890733b270ff8d9960c56c
- https://github.com/tensorflow/tensorflow/security/advisories/GHSA-7jvm-xxmr-v5cw
- https://github.com/tensorflow/tensorflow/commit/08b8e18643d6dcde00890733b270ff8d9960c56c
- https://github.com/tensorflow/tensorflow/security/advisories/GHSA-7jvm-xxmr-v5cw
Get alerted when CVE-2023-25662 or the next vulnerability affects your stack