What’s Vulnerable › Vulnerabilities
CVE-2023-25664: TensorFlow vulnerable to Heap Buffer Overflow in AvgPoolGrad
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-03-25 · updated 2026-06-17
- Weakness: CWE-120
Description
TensorFlow is an open source platform for machine learning. Prior to versions 2.12.0 and 2.11.1, there is a heap buffer overflow in TAvgPoolGrad. A fix is included in TensorFlow 2.12.0 and 2.11.1.
Affected products
- tensorflow: before 2.12.0 — fixed in 2.12.0
How to fix
Upgrade to a fixed version: tensorflow 2.12.0. Check the vendor advisory for mitigations.
References
- https://github.com/tensorflow/tensorflow/commit/ddaac2bdd099bec5d7923dea45276a7558217e5b
- https://github.com/tensorflow/tensorflow/security/advisories/GHSA-6hg6-5c2q-7rcr
- https://github.com/tensorflow/tensorflow/commit/ddaac2bdd099bec5d7923dea45276a7558217e5b
- https://github.com/tensorflow/tensorflow/security/advisories/GHSA-6hg6-5c2q-7rcr
Get alerted when CVE-2023-25664 or the next vulnerability affects your stack