What’s Vulnerable › Vulnerabilities
CVE-2023-25665: TensorFlow has Null Pointer Error in SparseSparseMaximum
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2023-03-25 · updated 2026-06-17
- Weakness: CWE-476
Description
TensorFlow is an open source platform for machine learning. Prior to versions 2.12.0 and 2.11.1, when `SparseSparseMaximum` is given invalid sparse tensors as inputs, it can give a null pointer error. A fix is included in TensorFlow version 2.12 and version 2.11.1.
Affected products
- tensorflow: before 2.12.0 — fixed in 2.12.0
How to fix
Upgrade to a fixed version: tensorflow 2.12.0. Check the vendor advisory for mitigations.
References
- https://github.com/tensorflow/tensorflow/commit/5e0ecfb42f5f65629fd7a4edd6c4afe7ff0feb04
- https://github.com/tensorflow/tensorflow/security/advisories/GHSA-558h-mq8x-7q9g
- https://github.com/tensorflow/tensorflow/commit/5e0ecfb42f5f65629fd7a4edd6c4afe7ff0feb04
- https://github.com/tensorflow/tensorflow/security/advisories/GHSA-558h-mq8x-7q9g
Get alerted when CVE-2023-25665 or the next vulnerability affects your stack