What’s Vulnerable › Vulnerabilities
CVE-2023-25668: TensorFlow vulnerable to heap out-of-buffer read in the QuantizeAndDequantize operation
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.8% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2023-03-25 · updated 2026-06-17
- Weakness: CWE-122
Description
TensorFlow is an open source platform for machine learning. Attackers using Tensorflow prior to 2.12.0 or 2.11.1 can access heap memory which is not in the control of user, leading to a crash or remote code execution. The fix will be included in TensorFlow version 2.12.0 and will also cherrypick this commit on TensorFlow version 2.11.1.
Affected products
- tensorflow: before 2.12.0 — fixed in 2.12.0
How to fix
Upgrade to a fixed version: tensorflow 2.12.0. Check the vendor advisory for mitigations.
References
- https://github.com/tensorflow/tensorflow/commit/7b174a0f2e40ff3f3aa957aecddfd5aaae35eccb
- https://github.com/tensorflow/tensorflow/security/advisories/GHSA-gw97-ff7c-9v96
- https://github.com/tensorflow/tensorflow/commit/7b174a0f2e40ff3f3aa957aecddfd5aaae35eccb
- https://github.com/tensorflow/tensorflow/security/advisories/GHSA-gw97-ff7c-9v96
Get alerted when CVE-2023-25668 or the next vulnerability affects your stack