What’s Vulnerable › Vulnerabilities
CVE-2023-25671: TensorFlow has segmentation fault in tfg-translate
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-03-25 · updated 2026-06-17
- Weakness: CWE-787
Description
TensorFlow is an open source platform for machine learning. There is out-of-bounds access due to mismatched integer type sizes. A fix is included in TensorFlow version 2.12.0 and version 2.11.1.
Affected products
- tensorflow: before 2.12.0 — fixed in 2.12.0
How to fix
Upgrade to a fixed version: tensorflow 2.12.0. Check the vendor advisory for mitigations.
References
- https://github.com/tensorflow/tensorflow/commit/2eedc8f676d2c3b8be9492e547b2bc814c10b367
- https://github.com/tensorflow/tensorflow/commit/760322a71ac9033e122ef1f4b1c62813021e5938
- https://github.com/tensorflow/tensorflow/security/advisories/GHSA-j5w9-hmfh-4cr6
- https://github.com/tensorflow/tensorflow/commit/2eedc8f676d2c3b8be9492e547b2bc814c10b367
- https://github.com/tensorflow/tensorflow/commit/760322a71ac9033e122ef1f4b1c62813021e5938
- https://github.com/tensorflow/tensorflow/security/advisories/GHSA-j5w9-hmfh-4cr6
Get alerted when CVE-2023-25671 or the next vulnerability affects your stack