What’s Vulnerable › Vulnerabilities
CVE-2023-25691: Apache Airflow Google Provider: Google Cloud Sql Provider Remote Command Execution
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-02-24 · updated 2026-06-17
- Weakness: CWE-20
Description
Improper Input Validation vulnerability in the Apache Airflow Google Provider. This issue affects Apache Airflow Google Provider versions before 8.10.0.
Affected products
- Apache Software Foundation Apache Airflow Google provider: before 8.10.0 — fixed in 8.10.0
How to fix
Upgrade to a fixed version: Apache Software Foundation Apache Airflow Google provider 8.10.0. Check the vendor advisory for mitigations.
References
- https://github.com/apache/airflow/pull/29497
- https://lists.apache.org/thread/zdr8ovfttbh7kj0lydgcw88tbt2nmkcy
- https://github.com/apache/airflow/pull/29497
- https://lists.apache.org/thread/zdr8ovfttbh7kj0lydgcw88tbt2nmkcy
Get alerted when CVE-2023-25691 or the next vulnerability affects your stack