What’s Vulnerable › Vulnerabilities
CVE-2023-25693: Sqoop Apache Airflow Provider Remote Code Execution Vulnerability
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.9% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-02-24 · updated 2026-06-17
- Weakness: CWE-20
Description
Improper Input Validation vulnerability in the Apache Airflow Sqoop Provider. This issue affects Apache Airflow Sqoop Provider versions before 3.1.1.
Affected products
- Apache-Airflow-Providers-Apache-Sqoop: before 3.1.1 — fixed in 3.1.1
How to fix
Upgrade to a fixed version: Apache-Airflow-Providers-Apache-Sqoop 3.1.1. Check the vendor advisory for mitigations.
References
- https://github.com/apache/airflow/pull/29500
- https://lists.apache.org/thread/79qn8g5xbq036f8crb115obvr22l52q4
- https://github.com/apache/airflow/pull/29500
- https://lists.apache.org/thread/79qn8g5xbq036f8crb115obvr22l52q4
Get alerted when CVE-2023-25693 or the next vulnerability affects your stack