What’s Vulnerable › Vulnerabilities
CVE-2023-25695: Information disclosure in Apache Airflow
- Severity: medium (CVSS 5.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-03-15 · updated 2026-06-17
- Weakness: CWE-209
Description
Generation of Error Message Containing Sensitive Information vulnerability in Apache Software Foundation Apache Airflow.This issue affects Apache Airflow: before 2.5.2.
Affected products
- Apache Airflow: before 2.5.2 — fixed in 2.5.2
How to fix
Upgrade to a fixed version: Apache Airflow 2.5.2. Check the vendor advisory for mitigations.
References
- https://github.com/apache/airflow/pull/29501
- https://lists.apache.org/thread/z8w6ckzs61ql365tv4d19k82o67r15p2
- https://github.com/apache/airflow/pull/29501
- https://lists.apache.org/thread/z8w6ckzs61ql365tv4d19k82o67r15p2
Get alerted when CVE-2023-25695 or the next vulnerability affects your stack