What’s Vulnerable › Vulnerabilities
CVE-2023-25696: Apache Airflow Hive Provider Beeline RCE
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 2.0% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-02-24 · updated 2026-06-17
- Weakness: CWE-20
Description
Improper Input Validation vulnerability in the Apache Airflow Hive Provider. This issue affects Apache Airflow Hive Provider versions before 5.1.3.
Affected products
- Apache Software Foundation Apache Airflow Hive Provider: before 5.1.3 — fixed in 5.1.3
How to fix
Upgrade to a fixed version: Apache Software Foundation Apache Airflow Hive Provider 5.1.3. Check the vendor advisory for mitigations.
References
- https://github.com/apache/airflow/pull/29502
- https://lists.apache.org/thread/99g0qm56wmgdxmbtdsvhj4rdnxhpzpml
- https://github.com/apache/airflow/pull/29502
- https://lists.apache.org/thread/99g0qm56wmgdxmbtdsvhj4rdnxhpzpml
Get alerted when CVE-2023-25696 or the next vulnerability affects your stack