What’s Vulnerable › Vulnerabilities
CVE-2023-25712: WordPress Opt-Out for Google Analytics Plugin <= 2.3.4 is vulnerable to Cross Site Scripting (XSS)
- Severity: medium (CVSS 4.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-04-07 · updated 2026-06-17
- Weakness: CWE-79
Description
Auth. (admin+) Stored Cross-Site Scripting (XSS) vulnerability in WP-Buddy Google Analytics Opt-Out plugin <= 2.3.4 versions.
Affected products
- WP-Buddy Google Analytics Opt-Out: before 2.3.5 — fixed in 2.3.5
How to fix
Upgrade to a fixed version: WP-Buddy Google Analytics Opt-Out 2.3.5. Check the vendor advisory for mitigations.
References
- https://patchstack.com/database/vulnerability/google-analytics-opt-out/wordpress-opt-out-for-google-analytics-plugin-2-3-4-cross-site-scripting-xss-vulnerability?_s_id=cve
- https://patchstack.com/database/vulnerability/google-analytics-opt-out/wordpress-opt-out-for-google-analytics-plugin-2-3-4-cross-site-scripting-xss-vulnerability?_s_id=cve
Get alerted when CVE-2023-25712 or the next vulnerability affects your stack