What’s Vulnerable › Vulnerabilities
CVE-2023-25727
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-02-13 · updated 2026-06-17
- Weakness: CWE-79
Description
In phpMyAdmin before 4.9.11 and 5.x before 5.2.1, an authenticated user can trigger XSS by uploading a crafted .sql file through the drag-and-drop interface.
Affected products
- phpMyAdmin: before 4.9.11; from 5.0.0 before 5.2.1 — fixed in 4.9.11, 5.2.1
How to fix
Upgrade to a fixed version: phpMyAdmin 4.9.11, 5.2.1. Check the vendor advisory for mitigations.
References
- https://www.phpmyadmin.net/security/PMASA-2023-1/
- https://lists.debian.org/debian-lts-announce/2025/04/msg00016.html
- https://www.phpmyadmin.net/security/PMASA-2023-1/
Get alerted when CVE-2023-25727 or the next vulnerability affects your stack