What’s Vulnerable › Vulnerabilities
CVE-2023-25751
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.7% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-06-02 · updated 2026-10-23
Description
Sometimes, when invalidating JIT code while following an iterator, the newly generated code could be overwritten incorrectly. This could lead to a potentially exploitable crash. This vulnerability affects Firefox < 111, Firefox ESR < 102.9, and Thunderbird < 102.9.
Affected products
- Mozilla Firefox: before 111.0 — fixed in 111.0
- Mozilla Firefox ESR: before 102.9 — fixed in 102.9
- Mozilla Thunderbird: before 102.9 — fixed in 102.9
How to fix
Upgrade to a fixed version: Mozilla Firefox 111.0; Mozilla Firefox ESR 102.9; Mozilla Thunderbird 102.9. Check the vendor advisory for mitigations.
References
- https://bugzilla.mozilla.org/show_bug.cgi?id=1814899
- https://www.mozilla.org/security/advisories/mfsa2023-09/
- https://www.mozilla.org/security/advisories/mfsa2023-10/
- https://www.mozilla.org/security/advisories/mfsa2023-11/
- https://bugzilla.mozilla.org/show_bug.cgi?id=1814899
- https://www.mozilla.org/security/advisories/mfsa2023-09/
- https://www.mozilla.org/security/advisories/mfsa2023-10/
- https://www.mozilla.org/security/advisories/mfsa2023-11/
Get alerted when CVE-2023-25751 or the next vulnerability affects your stack