What’s Vulnerable › Vulnerabilities
CVE-2023-25754: Apache Airflow: Privilege escalation using airflow logs
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 2.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-05-08 · updated 2026-06-17
- Weakness: CWE-270
Description
Privilege Context Switching Error vulnerability in Apache Software Foundation Apache Airflow.This issue affects Apache Airflow: before 2.6.0.
Affected products
- Apache Airflow: before 2.6.0 — fixed in 2.6.0
How to fix
Upgrade to a fixed version: Apache Airflow 2.6.0. Check the vendor advisory for mitigations.
References
- http://www.openwall.com/lists/oss-security/2023/05/08/2
- https://github.com/apache/airflow/pull/29506
- https://lists.apache.org/thread/3y83gr0qb8t49ppfk4fb2yk7md8ltq4v
- http://www.openwall.com/lists/oss-security/2023/05/08/2
- https://github.com/apache/airflow/pull/29506
- https://lists.apache.org/thread/3y83gr0qb8t49ppfk4fb2yk7md8ltq4v
Get alerted when CVE-2023-25754 or the next vulnerability affects your stack