What’s Vulnerable › Vulnerabilities

CVE-2023-2576: Incorrect Authorization in GitLab

Description

An issue has been discovered in GitLab CE/EE affecting all versions starting from 13.7 before 15.11.10, all versions starting from 16.0 before 16.0.6, all versions starting from 16.1 before 16.1.1. This allowed a developer to remove the CODEOWNERS rules and merge to a protected branch.

Affected products

How to fix

Upgrade to a fixed version: GitLab 15.11.10, 16.0.6, 16.1.1. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2023-2576 or the next vulnerability affects your stack