What’s Vulnerable › Vulnerabilities
CVE-2023-2578: Buy Me a Coffee < 3.7 - Admin+ Stored XSS
- Severity: medium (CVSS 4.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2023-07-10 · updated 2026-06-17
Description
The Buy Me a Coffee WordPress plugin before 3.7 does not sanitise and escape some of its settings, which could allow high privilege users such as admin to perform Stored Cross-Site Scripting attacks even when the unfiltered_html capability is disallowed (for example in multisite setup).
Affected products
- buymeacoffee Buy Me a Coffee – Button and Widget Plugin: before 3.7 — fixed in 3.7
How to fix
Upgrade to a fixed version: buymeacoffee Buy Me a Coffee – Button and Widget Plugin 3.7. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/4dad1c0d-bcf9-4486-bd8e-387ac8e6c892
- https://wpscan.com/vulnerability/4dad1c0d-bcf9-4486-bd8e-387ac8e6c892
Get alerted when CVE-2023-2578 or the next vulnerability affects your stack