What’s Vulnerable › Vulnerabilities
CVE-2023-2580: AI-Engine < 1.6.83 - Admin+ Stored XSS
- Severity: medium (CVSS 4.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2023-06-27 · updated 2026-06-17
Description
The AI Engine WordPress plugin before 1.6.83 does not sanitize and escape some of its settings, which could allow high-privilege users such as admin to perform Stored Cross-Site Scripting attacks even when the unfiltered_html capability is disallowed (for example, in multisite setup).
Affected products
- AI Engine: before 1.6.83 — fixed in 1.6.83
How to fix
Upgrade to a fixed version: AI Engine 1.6.83. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/7ee1efb1-9969-40b2-8ab2-ea427091bbd8
- https://wpscan.com/vulnerability/7ee1efb1-9969-40b2-8ab2-ea427091bbd8
Get alerted when CVE-2023-2580 or the next vulnerability affects your stack