What’s Vulnerable › Vulnerabilities
CVE-2023-25802: Roxy-WI has Path Traversal vulnerability
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.0% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2023-03-13 · updated 2026-06-17
- Weakness: CWE-22
Description
Roxy-WI is a Web interface for managing Haproxy, Nginx, Apache, and Keepalived servers. Versions prior to 6.3.6.0 don't correctly neutralize `dir/../filename` sequences, such as `/etc/nginx/../passwd`, allowing an actor to gain information about a server. Version 6.3.6.0 has a patch for this issue.
Affected products
- roxy-wi: before 6.3.6.0 — fixed in 6.3.6.0
How to fix
Upgrade to a fixed version: roxy-wi 6.3.6.0. Check the vendor advisory for mitigations.
References
- https://github.com/hap-wi/roxy-wi/commit/0054f25da7cf8c7480452f48e39308b5e392dc67
- https://github.com/hap-wi/roxy-wi/security/advisories/GHSA-qcmp-q5h3-784m
- https://github.com/hap-wi/roxy-wi/commit/0054f25da7cf8c7480452f48e39308b5e392dc67
- https://github.com/hap-wi/roxy-wi/security/advisories/GHSA-qcmp-q5h3-784m
Get alerted when CVE-2023-25802 or the next vulnerability affects your stack