What’s Vulnerable › Vulnerabilities
CVE-2023-25803
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.2% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2023-03-13 · updated 2026-06-17
- Weakness: CWE-22
Description
Roxy-WI is a Web interface for managing Haproxy, Nginx, Apache, and Keepalived servers. Versions prior to 6.3.5.0 have a directory traversal vulnerability that allows the inclusion of server-side files. This issue is fixed in version 6.3.5.0.
Affected products
- roxy-wi: before 6.3.5.0 — fixed in 6.3.5.0
How to fix
Upgrade to a fixed version: roxy-wi 6.3.5.0. Check the vendor advisory for mitigations.
References
- https://github.com/hap-wi/roxy-wi/security/advisories/GHSA-cv9w-j9gh-5j3w
- https://github.com/hap-wi/roxy-wi/security/advisories/GHSA-cv9w-j9gh-5j3w
Get alerted when CVE-2023-25803 or the next vulnerability affects your stack