What’s Vulnerable › Vulnerabilities
CVE-2023-25804: Roxy-WI vulnerable to Limited Path Traversal in name parameter
- Severity: medium (CVSS 5.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.8% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2023-03-15 · updated 2026-06-17
- Weakness: CWE-22
Description
Roxy-WI is a Web interface for managing Haproxy, Nginx, Apache, and Keepalived servers. Versions prior to 6.3.5.0 have a limited path traversal vulnerability. An SSH key can be saved into an unintended location, for example the `/tmp` folder using a payload `../../../../../tmp/test111_dev`. This issue has been fixed in version 6.3.5.0.
Affected products
- roxy-wi: before 6.3.5.0 — fixed in 6.3.5.0
How to fix
Upgrade to a fixed version: roxy-wi 6.3.5.0. Check the vendor advisory for mitigations.
References
- https://github.com/hap-wi/roxy-wi/security/advisories/GHSA-69j6-crq8-rrhv
- https://github.com/hap-wi/roxy-wi/security/advisories/GHSA-69j6-crq8-rrhv
Get alerted when CVE-2023-25804 or the next vulnerability affects your stack