What’s Vulnerable › Vulnerabilities
CVE-2023-25805: versionn Command Injection Vulnerability
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-02-20 · updated 2026-06-17
- Weakness: CWE-77
Description
versionn, software for changing version information across multiple files, has a command injection vulnerability in all versions prior to version 1.1.0. This issue is patched in version 1.1.0.
Affected products
- commenthol versionn: before 1.1.0 — fixed in 1.1.0
How to fix
Upgrade to a fixed version: commenthol versionn 1.1.0. Check the vendor advisory for mitigations.
References
- https://github.com/commenthol/versionn/commit/2ca128823efe962b37f2698f0eb530c2b124842d
- https://github.com/commenthol/versionn/security/advisories/GHSA-fj78-2vc5-f6cm
- https://github.com/commenthol/versionn/commit/2ca128823efe962b37f2698f0eb530c2b124842d
- https://github.com/commenthol/versionn/security/advisories/GHSA-fj78-2vc5-f6cm
Get alerted when CVE-2023-25805 or the next vulnerability affects your stack