What’s Vulnerable › Vulnerabilities
CVE-2023-25811: Persistent Cross site scripting (XSS) in Uptime Kuma
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2023-02-21 · updated 2026-06-17
- Weakness: CWE-79
Description
Uptime Kuma is a self-hosted monitoring tool. In versions prior to 1.20.0 the Uptime Kuma `name` parameter allows a persistent XSS attack. Users are advised to upgrade. There are no known workarounds for this vulnerability.
Affected products
- louislam uptime-kuma: before 1.20.0 — fixed in 1.20.0
How to fix
Upgrade to a fixed version: louislam uptime-kuma 1.20.0. Check the vendor advisory for mitigations.
References
- https://github.com/louislam/uptime-kuma/security/advisories/GHSA-553g-fcpf-m3wp
- https://github.com/louislam/uptime-kuma/security/advisories/GHSA-553g-fcpf-m3wp
Get alerted when CVE-2023-25811 or the next vulnerability affects your stack