What’s Vulnerable › Vulnerabilities
CVE-2023-25813: SQL Injection via replacements in sequelize
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.4% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2023-02-22 · updated 2026-06-17
- Weakness: CWE-89
Description
Sequelize is a Node.js ORM tool. In versions prior to 6.19.1 a SQL injection exploit exists related to replacements. Parameters which are passed through replacements are not properly escaped which can lead to arbitrary SQL injection depending on the specific queries in use. The issue has been fixed in Sequelize 6.19.1. Users are advised to upgrade. Users unable to upgrade should not use the `replacements` and the `where` option in the same query.
Affected products
- sequelize: before 6.19.1 — fixed in 6.19.1
How to fix
Upgrade to a fixed version: sequelize 6.19.1. Check the vendor advisory for mitigations.
References
- https://github.com/sequelize/sequelize/commit/ccaa3996047fe00048d5993ab2dd43ebadd4f78b
- https://github.com/sequelize/sequelize/issues/14519
- https://github.com/sequelize/sequelize/releases/tag/v6.19.1
- https://github.com/sequelize/sequelize/security/advisories/GHSA-wrh9-cjv3-2hpw
- https://github.com/sequelize/sequelize/commit/ccaa3996047fe00048d5993ab2dd43ebadd4f78b
- https://github.com/sequelize/sequelize/issues/14519
- https://github.com/sequelize/sequelize/releases/tag/v6.19.1
- https://github.com/sequelize/sequelize/security/advisories/GHSA-wrh9-cjv3-2hpw
Get alerted when CVE-2023-25813 or the next vulnerability affects your stack