What’s Vulnerable › Vulnerabilities
CVE-2023-25828: Authenticate Remote Code Execution in Pluck CMS
- Severity: high (CVSS 7.2 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-03-27 · updated 2026-06-17
- Weakness: CWE-434
Description
Pluck CMS is vulnerable to an authenticated remote code execution (RCE) vulnerability through its “albums” module. Albums are used to create collections of images that can be inserted into web pages across the site. Albums allow the upload of various filetypes, which undergo a normalization process before being available on the site. Due to lack of file extension validation, it is possible to upload a crafted JPEG payload containing an embedded PHP web-shell. An attacker may navigate to it directly to achieve RCE on the underlying web server. Administrator credentials for the Pluck CMS web interface are required to access the albums module feature, and are thus required to exploit this vulnerability. CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:C/C:H/I:H/A:H/E:P/RL:O/RC:C (8.2 High)
Affected products
- pluck-cms: before 4.7.16; 4.7.16-dev1, 4.7.16-dev2, 4.7.16-dev3, 4.7.16-dev4 — fixed in 4.7.16
How to fix
Upgrade to a fixed version: pluck-cms 4.7.16. Check the vendor advisory for mitigations.
References
- https://www.synopsys.com/blogs/software-security/pluck-cms-vulnerability/
- https://www.synopsys.com/blogs/software-security/pluck-cms-vulnerability/
Get alerted when CVE-2023-25828 or the next vulnerability affects your stack