What’s Vulnerable › Vulnerabilities
CVE-2023-25840: BUG-000154070 Stored XSS issue in the ArcGIS REST Services directory
- Severity: low (CVSS 3.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-07-21 · updated 2026-06-17
- Weakness: CWE-79
Description
There is a Cross-site Scripting vulnerability in ArcGIS Server in versions 11.1 and below that may allow a remote, authenticated attacker to create a crafted link which onmouseover wont execute but could potentially render an image in the victims browser. The privileges required to execute this attack are high.
Affected products
- Esri ArcGIS Server: from 10.8.1 before 11.1 — fixed in 11.1
How to fix
Upgrade to a fixed version: Esri ArcGIS Server 11.1. Check the vendor advisory for mitigations.
References
- https://www.esri.com/arcgis-blog/products/trust-arcgis/announcements/arcgis-server-security-2023-update-1-patch-available/
- https://www.esri.com/arcgis-blog/products/trust-arcgis/announcements/arcgis-server-security-2023-update-1-patch-available/
Get alerted when CVE-2023-25840 or the next vulnerability affects your stack